• Facebook
  • RSS Feed
  • Instagram
  • LinkedIn
  • Twitter
Jun 122008
 

So the short answer is that you can’t do this, but I thought I would try :

If you have a Windows 2003 domain (which has to be in Native Windows 2000 mode as a minimum) has Exchange 2007 installed in it. You can’t then install Exchange 2003.

When installing it, the Exchange 2003 setup doesn’t actually STOP me installing it.. but part way through the install, we get a nice failure message :

Setup failed whilst installing sub-component Microsoft Exchange Server-Level objects with error code 0x80072030 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed setup again.

0x80072030 = No such Object.

The log file shows :

[14:57:55] Using cached result for domain “/dc=com/dc=strangedom”
[14:57:55] The required permissions have not already been set
[14:57:55] Leaving ScDetermineIfLocalDomainServerGroupHasAlreadyBeenACLedOnExchangeCT
[14:57:55] Entering CAtomServer::ScSetOrgLevelPermissions
[14:57:55] Opening /dc=com/dc=strangedom/cn=Configuration/cn=Services/cn=Microsoft Exchange/cn=Active Directory Connections CAtomServer::ScSetOrgLevelPermissions (f:titaniumadminsrcudogexsetdatacomponentsservera_server.cxx:1871)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] CAtomServer::ScSetOrgLevelPermissions (f:titaniumadminsrcudogexsetdatacomponentsservera_server.cxx:1896)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] Leaving CAtomServer::ScSetOrgLevelPermissions
[14:57:55] CAtomServer::ScSetDSPermissions (f:titaniumadminsrcudogexsetdatacomponentsservera_server.cxx:632)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] Leaving CAtomServer::ScSetDSPermissions
[14:57:55] CAtomServer::ScAddOrRefreshDSObjects (f:titaniumadminsrcudogexsetdatacomponentsservera_server.cxx:366)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] CAtomServer::ScAddDSObjects (f:titaniumadminsrcudogexsetdatacomponentsservera_server.cxx:409)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] CBaseAtom::ScAdd (f:titaniumadminsrcudogsetupbasebasecompbaseatom.cxx:939)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] Service = ” CBaseServiceAtom::ScAdd (f:titaniumadminsrcudogsetupbasebasecompbasesvcatom.cxx:210)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] Leaving CBaseServiceAtom(Microsoft Exchange Server-Level Objects)::ScAdd
[14:57:55] CAtomServer::ScAdd (f:titaniumadminsrcudogexsetdatacomponentsservera_server.cxx:141)
Error code 0X80072030 (8240): There is no such object on the server.
[14:57:55] Leaving CAtomServer::ScAdd
[14:57:55] mode = ‘Install’ (61953) CBaseAtom::ScSetup (f:titaniumadminsrcudogsetupbasebasecompbaseatom.cxx:842)
Error code 0X80072030 (8240): There is no such object on the server.

That in English means you’ve just entered a world of pain.

This was also confirmed by two different Exchange gurus… but it’s something I couldn’t find out a definite answer on initially.

If you enjoyed this post, please consider leaving a comment or subscribing to the RSS feed to have future articles delivered to your feed reader.

  2 Responses to “Installing Exchange 2003 into an Exchange 2007 Forest”

  1. Same problem here – same configuration – same error – found this by google – do you have a solution at the moment?

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)